Trouble installing 311 accelerator

Aug 15, 2012 at 4:59 PM

Good day,

I've tried to install 311 acceleartor multiple times with no success. I can get the portal to launch correctly from Visual Studio 2010 but I cannot launch it from my localhost. Furthermore, I'm experiencing some problems with creating new service requests. I've followed the procedure in the  document named 1_Microsoft_311_installation.docx

Launching the portal from the localhost sends me back a generic server error : "FaultException: The server was unable to process the request due to an internal error. For more information...".

Trying to create a new service request (any type of service request), throws this error : "The Ms311Plugins.NewCustomServiceRequestPlugin plugin can only be used on entities defined in msa_servicerequesttype in CRM"

It might have something to do with my development environment configuration since I'm running my instance of CRM on a Virtual Machine with no access to internet.

Can anyone walk me through a solution to this problem?

 

Thanks,

 

Ggilmann

Aug 16, 2012 at 11:18 PM

Your configuration should work as this is the same as the development environment we built the 311 accelerator for.

As for your localhost error, I would need more information about how you set up the IIS website to host the site.

As for the FaultException, that is likely that you don't have your service urls or DNS configured properly for your CRM environment.

As for the plugin error - that is due to you registering the plugin for an entity that does not have a row in the service request types entity that is part of the 311 solutions.  Please see the documentation on how to properly set up your own custom entity.

Aug 17, 2012 at 1:32 PM

Thank you Shan,

You sure are dedicated to Microsoft CRM and the 311 accelerator, you've answered virtually all the questions about the 311 accelerator that I see on the web!

I reinstalled everything on an internet enabled VM and it seems everything now works fine as far as my IIS problems go. As for the plugin, you were also right. Once I loaded all the data, as the second installation document detailed, everything worked out fine. I'm new to CRM and 311 and it seems it all was a bit much for me at first!

Anyways, thank you very much! I still have a couple of problems to iron out but I'm doing much better now!

 

Ggilmann